Jump to content


Photo

Test e-mail works, real alert does not


  • Please log in to reply
9 replies to this topic

#1 aml276

aml276

    Newbie

  • Members
  • Pip
  • 7 posts

Posted 28 December 2010 - 07:44 PM

I've read all the posts I can find on setting up e-mail alerts and none of them seem to quite cover my situation, although the one about detect automatically or use from options and how it chooses what server or mx record to utilise was an eye opener.

Have just set up TNM 1.1.3 (1550) to alert on low disk space. Initially had 2 alerts (one for red - when below 10% free space & a second one for green - when returned above 10%)but have now combined then into the one alert using the macro's and red & green check boxes (as details in another post) I have my domain exchange server set within options and have selected 'use from options' on the alert. When I use the test button on the alert configuration screen I get the alert 90% of the time. This may be because I have adjusted the sender & recipient addresses frequently to try and get the alert to work unattended. I am yet to ever receive the alert when I make the free space go below 10%. I have tried changing the SMTP setting to detect automatically, and have also tried using an external mail server that I manage using it's mail domain in the sender &/or recipient address but with less success in testing and still never when the server actually goes below 10%

In the TNM console logging (the bottom half of the screen) I see the monitor event that it has gone below 10% and then when it has returned to normal, but nothing is logged about attempting to send and alert, not even when I just test it, nothing is logged.

Does anybody have any other suggestions?

In case it matters, I have TNM installed on a Vista Business 32bit SP2 machine and the PC is attached to a network domain and I am trying to utilise internal e-mail addresses and a local exchange server.

#2 aml276

aml276

    Newbie

  • Members
  • Pip
  • 7 posts

Posted 28 December 2010 - 08:53 PM

I think I've found the cause, but not the solution, as I had installed the TNM setup program using "run as administrator" on the Vista machine but after spending 3 days troubleshooting this I found an old XP machine and have setup the same configuration and the alerts work perfectly. Looks like Vista strikes again. Have also tried to run/open TNM program with 'run as administrator' and alerts now work about 50% of the time.

Does anyone have any idea what else I need to configure or disable on the Vista machine?

#3 aml276

aml276

    Newbie

  • Members
  • Pip
  • 7 posts

Posted 29 December 2010 - 10:31 PM

Having same issue on Windows Server 2008. All part of the same issue I think but in Win2008 I've set it up fully (8 servers to monitor disk space, with 8 monitors configured identically) The first 4 I set up test e-mail sends ok, real alert sends ok MOST of the time but not always, the other 4 servers test e-mail only works occasionally, real alert is yet to be set for these 4 servers.

Is this a UAC type issue? Does anyone have any suggestions on what I need to change?

#4 aml276

aml276

    Newbie

  • Members
  • Pip
  • 7 posts

Posted 30 December 2010 - 03:09 PM

Worked part of it out. Seems to be caused by the scan wizard determining the device name as servername.domainname.com etc. As soon as I made the other 4 servers just servername all test e-mails started working, so I have made all of them just servername to ensure the first 4 servers don't start playing up at some point. Still can't get a real alert to come through.

#5 aml276

aml276

    Newbie

  • Members
  • Pip
  • 7 posts

Posted 30 December 2010 - 05:41 PM

Finally sorted it all out. Using the traffic redirect tool mentioned here http://www.softinven...p?showtopic=794 I was able to determine that it's the small buffer size bug in the send mail function of TNM that is mentioned here http://www.softinven...p?showtopic=788 I used the 'default message' macros in the body and it was 4 characters too long when an actual alert was generated as it included the %results% text, where the test just has "" for results. Would have thought this issue fixed as it was noted over 6 months ago.

Suggestion to TNM developers - if this buffer size fix is not available in the next update, perhaps just shorten the default message in the next build to save a lot of frustration. I.E. I removed "Results:" from my message as the %results% is sufficient notification.

Furthermore re not seeing any evidence in the TNM logs about it sending messages - for anybody else struggling with troubleshooting e-mail issues it's not in the default log shown on the screen, it's in the EXECUTED ACTIONS log (the last sun/cog type icon in the logs area) - refer here http://docs.softinve...ns_journalizing

#6 Zak

Zak

    Administrator

  • Root Admin
  • PipPipPip
  • 747 posts
  • Gender:Male

Posted 05 January 2011 - 07:20 AM

Thank you for sharing your experience, it might be helpful for other users.

Indeed, there is such a bug with email sending buffer size which should be fixed in the nearest update. So the problem was not in the full hostname of the monitored device as such, but in its length when inserted into the alert message and sent by email.

And concerning the action log, it's really good sometimes to read a manual or at least look at the screenshots there ;)
Softinventive Lab support

#7 Souza

Souza

    Newbie

  • Members
  • Pip
  • 1 posts

Posted 10 March 2011 - 01:59 PM

I'm having the same problem ...
I will send the SMTP log:
(My speak Português:)

10/3/2011 18:32:42 Enviar mensagem de correio electrónico [1] @ ICMP SMTP server wrong reply (551 Sender address is not valid for your login. Check your email program settings. ). true




--- Flavio. Souza ---

#8 Zak

Zak

    Administrator

  • Root Admin
  • PipPipPip
  • 747 posts
  • Gender:Male

Posted 18 March 2011 - 02:38 AM

It doesn't seem like the same problem. You are specifying incorrect sender address, which does not correspond to your login. For example, you authorize on the SMTP server as "user@example.com" and specify another sender address like "othername@otherserver.com". Some SMTP servers consider this as email forging and do not allow to send emails with sender address different from login. So you need to check your SMTP and email alert settings, as prompted by the mail server.
Softinventive Lab support

#9 Spheron

Spheron

    Newbie

  • Members
  • Pip
  • 3 posts

Posted 25 March 2011 - 04:37 AM

Hello @all,


Administrator wrote:
>Indeed, there is such a bug with email sending buffer size which should be fixed in the nearest update. So the problem was not in the full >hostname of the monitored device as such, but in its length when inserted into the alert message and sent by email.


Is an update of TNM planned that fix this issue? If yes, when will it come?


Greets
Spheron

#10 Zak

Zak

    Administrator

  • Root Admin
  • PipPipPip
  • 747 posts
  • Gender:Male

Posted 28 March 2011 - 02:32 AM

Hello Spheron,

This issue is going to be fixed soon, but unfortunately I cannot give an exact date.

P.S. I have merged your topic into this one, becase they are directly related.
Softinventive Lab support




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users