Jump to content


Photo

Manual Scan - RPC Server is unavailable. Help Please


  • Please log in to reply
3 replies to this topic

#1 FuzzyReets

FuzzyReets

    Newbie

  • Members
  • Pip
  • 2 posts

Posted 26 November 2009 - 06:14 AM

Hi folks. Trying out the software for network inventory purposes. I can't get the scan to work unless I remove the firewall from the client which isn't an option. I've done the following based on info in the FAQ but still receive "RPC Server Unavailable" when I scan.

- add ports 135, 139, 445
- enable wmi in firewall
- create gp change Local Computer Policy -> Computer Configuration -> Administrative Templates -> Network -> Network Connections -> Windows Firewall -> Domain Profile or Standard Profile -> Windows Firewall: Allow remote administration exception -> Action -> Properties -> Enabl
- run netsh firewall set service RemoteAdmin enable

Server is sever 2008 R2 and clients are Windows 7 Ultimate. Please advise. Thanks.

#2 Zak

Zak

    Administrator

  • Root Admin
  • PipPipPip
  • 747 posts
  • Gender:Male

Posted 26 November 2009 - 06:25 AM

Do you use domain group policy for firewall? Then you need to make these changes in that policy. Also run "gpupdate /force" on the clients to update the policy right now.
Also try to enable "File and Printer Sharing" in the firewall, then go to "Options - Connection", select "Auto-deployed agent method (SMB)" and uncheck the option "Try another method if selected fails".
Softinventive Lab support

#3 FuzzyReets

FuzzyReets

    Newbie

  • Members
  • Pip
  • 2 posts

Posted 02 December 2009 - 04:05 PM

Do you use domain group policy for firewall? Then you need to make these changes in that policy. Also run "gpupdate /force" on the clients to update the policy right now.
Also try to enable "File and Printer Sharing" in the firewall, then go to "Options - Connection", select "Auto-deployed agent method (SMB)" and uncheck the option "Try another method if selected fails".


Okay I've done the above except that I don't know where to go for " then go to "Options - Connection", select "Auto-deployed agent method (SMB)" and uncheck the option "Try another method if selected fails". " Please explain further. Yes these computers are controlled by group policy Server 2008 R2 server. Thanks.

#4 Zak

Zak

    Administrator

  • Root Admin
  • PipPipPip
  • 747 posts
  • Gender:Male

Posted 03 December 2009 - 07:24 AM

That means open the "Options" window (either in main menu "File - Options" or just click "Options" on the main toolbar), and then open the "Connection" tab in the options window. There you will see the settings that I've mentioned.
Softinventive Lab support




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users