Jump to content


Photo

How do I select all the computers in the tree to run reports against?


  • Please log in to reply
10 replies to this topic

#1 mmatheny

mmatheny

    Advanced Member

  • Members
  • PipPipPip
  • 76 posts

Posted 30 January 2008 - 02:58 PM

I can't figure out the logic - sometimes it will select all, sometimes it won't.
Mike

#2 Zak

Zak

    Administrator

  • Root Admin
  • PipPipPip
  • 747 posts
  • Gender:Male

Posted 31 January 2008 - 06:02 AM

When you enter Report Builder (by pressing "Report Builder" button or selecting any report from the menu), currently selected node becomes selected for reports. If the group was selected, all subnodes become selected. Thus, if root node "Network" was selected, then all computers and groups become selected.
To select or deselect all computers when you are already in Report Builder, you just need to check or uncheck the root node - "Network". The same with selecting/deselecting whole groups or subgroups, you just check or uncheck the group node.
Softinventive Lab support

#3 mmatheny

mmatheny

    Advanced Member

  • Members
  • PipPipPip
  • 76 posts

Posted 31 January 2008 - 06:30 AM

I am unable to select the root node - neither clicking or double clicking will select it.
Mike

#4 mmatheny

mmatheny

    Advanced Member

  • Members
  • PipPipPip
  • 76 posts

Posted 31 January 2008 - 07:03 AM

Just checked again, and if I enter the report builder with anything except the root node selected, I cannot select all computers except bu selecting one at a time. I have to exit, make sure root node is selected, then go to into report builder again.
Mike

#5 Zak

Zak

    Administrator

  • Root Admin
  • PipPipPip
  • 747 posts
  • Gender:Male

Posted 31 January 2008 - 08:31 AM

In general view mode, when I say "selected", I mean "highlighted" and you cannot select more than one node at a time.
Have you noticed that when you switch to Report Builder, each node's icon is shifted to the right a bit and there is a space for a checkmark? So when in Report Builder you just tick that empty place and the checkmark appears, and this is what we call "selected for reports". If you tick the checkmark again, it disappears, that is the node is deselected. You can do this with any node, including the root node and the checking or unchecking is propagated to all its subnodes.
Perhaps the absence of boxes for checkmarks is a bit confusing, but we thought it would look better this way...
Softinventive Lab support

#6 mmatheny

mmatheny

    Advanced Member

  • Members
  • PipPipPip
  • 76 posts

Posted 31 January 2008 - 10:30 AM

Sorry - it doesn't work that way! I can select any SINGLE computer by ticking in the empty space, but ticking the same on the root node does nothing.
Mike

#7 Zak

Zak

    Administrator

  • Root Admin
  • PipPipPip
  • 747 posts
  • Gender:Male

Posted 31 January 2008 - 11:17 AM

Strange, I can do that...
Try other way, select (highlight) the root node in the report mode and press space key.
Softinventive Lab support

#8 mmatheny

mmatheny

    Advanced Member

  • Members
  • PipPipPip
  • 76 posts

Posted 01 February 2008 - 08:01 AM

Strange, I can do that...
Try other way, select (highlight) the root node in the report mode and press space key.





Space works! Thanx!!
Mike

#9 mmatheny

mmatheny

    Advanced Member

  • Members
  • PipPipPip
  • 76 posts

Posted 20 February 2008 - 12:30 PM

Just a note - I am able to select and unselect the whole tree with a mouse click in the new preview version.
Mike

#10 Zak

Zak

    Administrator

  • Root Admin
  • PipPipPip
  • 747 posts
  • Gender:Male

Posted 21 February 2008 - 08:15 AM

That's nice, and you can already update to the new release version now (see here) and hopefully it will work there too :) (at least we did not touch selecting functions since the preview version).
Softinventive Lab support

#11 mmatheny

mmatheny

    Advanced Member

  • Members
  • PipPipPip
  • 76 posts

Posted 22 February 2008 - 02:46 PM

Yeah got it and it work fine!
Mike




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users