Jump to content


Photo

Launching TNM from batch script or scheduled task?


  • Please log in to reply
1 reply to this topic

#1 AHSCIS

AHSCIS

    Newbie

  • Members
  • Pip
  • 1 posts

Posted 29 January 2016 - 08:36 AM

I've been running TNM for a few months and I've been having trouble launching the program via command line, batch script or scheduled task.

The server it's running on doubles as my veeam backup server and when those jobs start saturating the network card TNM starts throwing latency related emails at my phone (as it should do). 

To prevent this I started running a script before the backups run that simply executes a taskkill /F /IM tnm.exe (which works fine to shutdown the monitoring).

After the jobs are done, I've been trying to restart TNM using multiple methods. 

First I tried simply running a batch script with this line:

start "C:\Program Files (x86)\Total Network Monitor\tnm.exe"

after that didn't work perfectly, I tried setting the same command in a scheduled task (on demand) running under local (eventually domain) administrator credentials.

 

Both methods result in the same behavior:

 

The tnm process starts (can see it running in task manager) but the GUI never appears on the screen.

In this state, it appears to still be monitoring because it will send emails to me, but we project the status screen on our wall in the NOC and every morning I have to remote into the server, kill tnm.exe and manually restart it by clicking on the icon for the GUI to initialize.

 

I don't understand this.  The icon I click on goes to the exact same path without any special flags as my scripts start.  At first I thought something was going wrong when I shut TNM down since (for whatever reason) when I close TNM it ALWAYS asks if I want to save the project (which I have already saved and haven't made any changes to).

 

While reading today I saw that it's possible to install as a service and I suppose I could perform a net stop command to kill the service but the forum is full of posts about problems with the service and I don't want to make things worst.

 

Anyone got any ideas why this won't start correctly from command line?  I'm pulling my hair out trying to figure this out.

 

It doesn't look like anyone really replies to these posts in the forum but I thought I'd throw it out there anyways.  Hope someone can help.



#2 Armo

Armo

    Advanced Member

  • Administrators
  • PipPipPip
  • 73 posts
  • Gender:Male

Posted 01 February 2016 - 06:21 AM

Hello.

 

Please tell us what version of TNM you're using?






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users