Jump to content


Photo

Total Network Monitor sending monitor "Green" emails constantly


  • Please log in to reply
4 replies to this topic

#1 mattb

mattb

    Newbie

  • Members
  • Pip
  • 2 posts

Posted 17 April 2013 - 06:02 PM

We have been having an issue with our Network Monitoring installation where devices are sending monitor "green" emails evern when the state of the monitor has not changed. We have an ICMP monitor on several servers to ensure they are online, when the monitor turns "red" it takes several actions and when it turns "green" again it send an email to the team to let everyone know the issue is resolved. However one server in particular will SPAM us with over 50 "greens" a day even though there as been no issue.

 

We are at a lost to explain this behaviour. We have ran Ping tests from a command line to ensure the monitor is not picking up an issues it is not reporting properly, still SPAMS us without the server dropping a single Ping. We have checked logs and the monitor itself for clues and all it says is that it has changed to "green" 50 times in a row.

 

Please help us before it drives us insane and we just junk the whole project.



#2 Zak

Zak

    Administrator

  • Root Admin
  • PipPipPip
  • 747 posts
  • Gender:Male

Posted 17 April 2013 - 11:20 PM

Maybe you have just enabled the option "repeatedly" in the action properties? This option makes the program execute the action (send an email in this case) infinitely (each check period) until the monitor is in the specified state. It's usually used for red state of course (i.e. notify each 10 minutes that there are still problems with the device, until it's resolved). If so, just disable this option and that's all. If you need it to be enabled for the red state, create two different actions: one for red with "repeatedly" on, and another for green with "repeatedly" off.


Softinventive Lab support

#3 ali_k

ali_k

    Newbie

  • Members
  • Pip
  • 1 posts

Posted 19 April 2013 - 12:35 AM

I am experiencing similar issues.  I have monitors setup to ping and send me red, green and black alerts on email after 5 times in a row, it works fine with the red alerts, sending me an email if after 5 attempts there is no response (changed this from the default 1 as I was receiving alerts when there was just a couple of dropped pings), however even without sending me an alert for a red issue it will send me a green alert.  I dont have the 'repeatedly' option ticked as you suggest above.

 

I understand why its going green as its usually when the monitor has gone red on the system then back to green, however, I dont want it to work this way as like mattb says you get flooded with green alerts.

 

The way I think I need to get it to work is like a conditional rule to say 'If a red alert is emailed, then the monitor goes green, send a green alert' rather than what its doing at the moment is sending green alerts just when it turns from red to green in the system.  Is this possible?

 

At the moment I have, for example, a ping monitor to ping 'server a' and in the alerts section I have 1 alert setup which does red green and black - should I have separate alerts for red, green and black?

 

Hopefully you can clarify.

 

Many thanks

 

PS great product, much better than any other "free" monitoring solutions I have tried, and better than a lot of the products that cost a lot of money!



#4 mattb

mattb

    Newbie

  • Members
  • Pip
  • 2 posts

Posted 21 April 2013 - 02:20 PM

Hi Zak, Thanks for the reply! Yes I have checked this option and it is not enabled which I thought would be the case as I set one server up and the just copied it through with the Project Editor.

 

Just as further information the server monitor that was spamming us with email has now settled down without making any changes to the network or the monitoring configuration. Also interesting to note that although we have multiple actions set on this monitor, eg play a sound, pop up a message, write to log etc,  but it only affects the email tasks (sending to 3 people). We still get the odd email through about 2 a day from monitored devices saying they are "green".

 

Any further ideas would be appreciated, apart from this it is a very good and useful product.

 

Matt



#5 Zak

Zak

    Administrator

  • Root Admin
  • PipPipPip
  • 747 posts
  • Gender:Male

Posted 21 May 2013 - 07:15 AM

Matt,

That is, you say that the same monitor has multiple actions, but only emails are being sent incorrectly? No writing to log at the same time?

You might have noticed our discussion with ali_k, is it the same situation with you? I.e. do you use "N times in a row", then the monitor gets red for only one check period, then back to green, and then it will send all green alerts, because there was a color (state) change. But in this case all actions should have been executed...

 

ali_k,

I understand what you want to say. It's really somewhat dumb and straight logic at the moment, which lead to this situation. Unfortunately there is no fix at the moment, but hopefully we'll come up with one when we revive TNM development.


Softinventive Lab support




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users