Jump to content


Photo

Bad Temp File Names


  • Please log in to reply
2 replies to this topic

#1 downer

downer

    Newbie

  • Members
  • Pip
  • 3 posts

Posted 09 February 2012 - 04:35 AM

I have encountered the following problem with TNI 2 on a Windows XP machine:
Whenever I scan a Linux system, the scanner attempts to create a temporary file in
c:\Documents\[Username]\Local Settings\Temp\TNITEMPSCANDIR\*
with a filename containing a question mark (?).
Naturally, Windows refuses to create such a file, since question marks are not allowed in filenames.
When scanning a Windows PC (the one I'm working on, since the rest of the network runs Linux), no such error occurs.

System setup is as follows:
1 Windows XP machine running TNI 2.0.4 Trial Version (won't upgrade to full unless it's working, obviously)
1 Centos 6 server
15 Centos 6 clients

All machines are successfully detected, and the scan runs up to 95% before quitting. I used the root account on the Linux machines, since Centos doesn't normally allow sudo. On the Windows machine I use an administrator account.

Thanks in advance,
André

*That's probably not the correct name, I use the German version of XP, where all the paths have neat German names, which makes googling the error so much easier ....

#2 Zak

Zak

    Administrator

  • Root Admin
  • PipPipPip
  • 688 posts
  • Gender:Male

Posted 09 February 2012 - 04:45 AM

Please download the updated Linux scanner and unpack the archive to the program's installation directory (overwrite existing file):
http://www.softinven...tnilinagent.zip
Then try to scan your Linuxes again. Les us know the results.
Softinventive Lab support

#3 downer

downer

    Newbie

  • Members
  • Pip
  • 3 posts

Posted 09 February 2012 - 06:08 AM

Thank you for your prompt help, Zak. Now it works perfectly.




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users